Jump to content
  • 0

Erro ao Compilar Cliente no Cmake


Slytherin

Question

Bom dia galera estou com esse problema alguem ajuda? 

 

CMake Warning (dev) in CMakeLists.txt:
No project() command is present. The top-level CMakeLists.txt file must
contain a literal, direct call to the project() command. Add a line of
code such as

project(ProjectName)

near the top of the file, but after cmake_minimum_required().

CMake is pretending there is a "project(Project)" command on the first
line.
This warning is for project developers. Use -Wno-dev to suppress it.

The C compiler identification is GNU 6.3.0

The CXX compiler identification is GNU 6.3.0

Detecting C compiler ABI info

Detecting C compiler ABI info - done

Check for working C compiler: C:/MinGW/bin/gcc.exe - skipped

Detecting C compile features

Detecting C compile features - done

Detecting CXX compiler ABI info

Detecting CXX compiler ABI info - done

Check for working CXX compiler: C:/MinGW/bin/g++.exe - skipped

Detecting CXX compile features

Detecting CXX compile features - done

CMake Warning (dev) at CMakeLists.txt:152 (set):
implicitly converting 'Git commit string (intended for releases)' to
'STRING' type.
This warning is for project developers. Use -Wno-dev to suppress it.

CMake Warning (dev) at CMakeLists.txt:153 (set):
implicitly converting 'Git revision string (intended for releases)' to
'STRING' type.
This warning is for project developers. Use -Wno-dev to suppress it.

Link to static libraries: ON

Build type: RelWithDebInfo

Build commit: devel

Build revision: 0

Looking for pthread.h

Looking for pthread.h - not found

Found Threads: TRUE

Found Boost: C:/MinGW/include (found suitable version "1.50.0", minimum required is "1.48.0") found components: system thread filesystem chrono date_time

Found Lua: C:/MinGW/lib/liblua51.dll.a (found version "5.1.5")

LuaJIT: OFF

Found PhysFS: C:/MinGW/lib/libphysfs.dll.a

Found OpenSSL: C:/MinGW/lib/libcrypto.dll.a (found version "1.0.1c")

Found ZLIB: C:/MinGW/lib/libz.dll.a (found version "1.2.7")

Debug information: ON

Crash handler: ON

CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 3.19)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

Configuring done

 

image.thumb.png.56453033b41799a737fc118efc6d27e3.png

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

×
×
  • Create New...