Jump to content
  • 0

Pokémons sem sprite


Gutoooxd2
 Share

Question

Primeiramente, agradeço aos que se proporem a tentar me ajudar e peço desculpa aos admins caso esteja criando o tópico na área errada (essa é a primeira vez que preciso recorrer a abrir um novo tópico no fórum)

 

Estou desenvolvendo um server de Poketibia com base no Hand e Cyan.

 

Até ai tudo ok. 

Exportei as sprites de um server com os megas e shinys que eu queria (salvei em todos os formatos que o object builder 0.3.4 permite.)

 

E fui lá adicionar os pokés no meu server. 

 

Funcionalmente falando, não tenho problema. Os pokés são capturados, tem drop, xp e funcionam normalmente com um player, exceto por um fator. 

 

Todo e qualquer pokémon que eu tentei adicionar (sendo shiny ou não) ao ser summonado como selvagem ou mesmo ser retirado da ball fica com a imagem transparente.

 

Tentei basear o LookType da configuração para um outro pokémon que já estava com sprit para ver se resolveria e ainda assim seguem sem sprite. 

 

Abri o meu Object Builder e criei uma nova aera onde importei a sprite do shiny (também tentei cria-la cortando a imagem JPNG) porém ainda assim continua transparente. 

 

 

Vi alguns tópicos pedindo para verificar na pasta Data em Lib para qual sprite o pokémon está direcionando porém, não encontro esse arquivo (107-main table).

 

Peço por gentileza que caso a solução se resuma em abrir esse arquivo e realizar a configuração para o sprite correto, que seja apresentado o caminho para acesso do arquivo(já que ele não consta na pasta Lib do meu server)

 

 

Obrigado desde já !! 

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Preciso ver como esta sua Config.lua 

 

Em Lib/Configuration.lua mande ela aqui, e Informe os Pokemons que foram Adicionados... se nada estiver errado la.. Provavelmente a forma de Compilar as Sprites que vc usou é invalida.. tente ( Extendido ) Sem transparencia... Ou Tente os Dois... Mas Use um Rollback das Spr Para Readicionar Tudo Novamente.

Link to comment
Share on other sites

  • 0

Seu cliente está configurado para reconhecer sprites transparentes?
Voce compilou o .SPR (Arquivo de sprites) em modo transparencia ou sem transparencia? Marcou Extendido?
Quando voce for exportar um pokemon, recomendo exportar o arquivo em .obd e importar na onde voce quer usar.

Link to comment
Share on other sites

  • 0
14 horas atrás, brazvct disse:

Seu cliente está configurado para reconhecer sprites transparentes?
Voce compilou o .SPR (Arquivo de sprites) em modo transparencia ou sem transparencia? Marcou Extendido?
Quando voce for exportar um pokemon, recomendo exportar o arquivo em .obd e importar na onde voce quer usar.

Olha, eu não tinha pensado nisso, mas, fiz alguns testes. 

Estava fazendo replace no Object Builder em lugares onde existiam monstros do tibia como "Demon" mas, notei que ao abrir o client após a edição, continuava recebendo o mesmo monstro anterior, no caso, um "Demon" :

855631354_erropokemonhoundoom.thumb.png.38d90716aa507a2caca0ad98c755a599.png

 

Então, fui e compilei com o Object Builder novamente o arquivo tibia.dat e tibia.spr, porém, ao abrir o client outra vez ele havia bugado. O Mapa ficou todo desconfigurado e eu simplesmente não consigo fazer mais nada:
414241894_erropokemonhoundoom.thumb.png.3f72e2d52f0740b7fa0c972f50e44fdd.png

 

Acredito que o problema realmente é o Client, uma vez que continua apontando para imagens que já foram reeditadas.
A questão é que tentei todas as possibilidades com as versões 8.54V1,2 e 3. Usando transparencia e sem ela. Versão extendida ou não e suas combinações possíveis. 

Mas, o client continua bugando.
Se a minha analise estiver certa...

Alguem me salva por favor rs 

Observação:

Eu não estou conseguindo descobrir qual é a versão do meu client. 
Se alguem puder me ajudar a descobrir a versão, eu vou poder gerar o .dat na versão correta.

Queria entender também se existe algum problema em usar o object builder para gerar esses dois arquivos ou se eu realmente preciso usar o dat editor (o meu não abre os arquivos do server que uso de base)

Não sei se ajuda na solução...

O .dat e .spr originais do client não são editaveis no Obejct Buildes. 
Eu tento abrir e fala que a versão não é suportada

Link to comment
Share on other sites

  • 0
11 horas atrás, Gutoooxd2 disse:

Olha, eu não tinha pensado nisso, mas, fiz alguns testes. 

Estava fazendo replace no Object Builder em lugares onde existiam monstros do tibia como "Demon" mas, notei que ao abrir o client após a edição, continuava recebendo o mesmo monstro anterior, no caso, um "Demon" :

855631354_erropokemonhoundoom.thumb.png.38d90716aa507a2caca0ad98c755a599.png

 

Então, fui e compilei com o Object Builder novamente o arquivo tibia.dat e tibia.spr, porém, ao abrir o client outra vez ele havia bugado. O Mapa ficou todo desconfigurado e eu simplesmente não consigo fazer mais nada:
414241894_erropokemonhoundoom.thumb.png.3f72e2d52f0740b7fa0c972f50e44fdd.png

 

Acredito que o problema realmente é o Client, uma vez que continua apontando para imagens que já foram reeditadas.
A questão é que tentei todas as possibilidades com as versões 8.54V1,2 e 3. Usando transparencia e sem ela. Versão extendida ou não e suas combinações possíveis. 

Mas, o client continua bugando.
Se a minha analise estiver certa...

Alguem me salva por favor rs 

Observação:

Eu não estou conseguindo descobrir qual é a versão do meu client. 
Se alguem puder me ajudar a descobrir a versão, eu vou poder gerar o .dat na versão correta.

Queria entender também se existe algum problema em usar o object builder para gerar esses dois arquivos ou se eu realmente preciso usar o dat editor (o meu não abre os arquivos do server que uso de base)

Não sei se ajuda na solução...

O .dat e .spr originais do client não são editaveis no Obejct Buildes. 
Eu tento abrir e fala que a versão não é suportada

 

Preciso do Client e Pastas Monster... Porfavor Mande WA.me/557199376070 no whatsapp ou discord PokeStars2.0 Procura la e marca [ADM] Cloud

Link to comment
Share on other sites

  • 0
Em 03/01/2021 em 12:03, Gutoooxd2 disse:

Olha, eu não tinha pensado nisso, mas, fiz alguns testes. 

Estava fazendo replace no Object Builder em lugares onde existiam monstros do tibia como "Demon" mas, notei que ao abrir o client após a edição, continuava recebendo o mesmo monstro anterior, no caso, um "Demon" :

855631354_erropokemonhoundoom.thumb.png.38d90716aa507a2caca0ad98c755a599.png

 

Então, fui e compilei com o Object Builder novamente o arquivo tibia.dat e tibia.spr, porém, ao abrir o client outra vez ele havia bugado. O Mapa ficou todo desconfigurado e eu simplesmente não consigo fazer mais nada:
414241894_erropokemonhoundoom.thumb.png.3f72e2d52f0740b7fa0c972f50e44fdd.png

 

Acredito que o problema realmente é o Client, uma vez que continua apontando para imagens que já foram reeditadas.
A questão é que tentei todas as possibilidades com as versões 8.54V1,2 e 3. Usando transparencia e sem ela. Versão extendida ou não e suas combinações possíveis. 

Mas, o client continua bugando.
Se a minha analise estiver certa...

Alguem me salva por favor rs 

Observação:

Eu não estou conseguindo descobrir qual é a versão do meu client. 
Se alguem puder me ajudar a descobrir a versão, eu vou poder gerar o .dat na versão correta.

Queria entender também se existe algum problema em usar o object builder para gerar esses dois arquivos ou se eu realmente preciso usar o dat editor (o meu não abre os arquivos do server que uso de base)

Não sei se ajuda na solução...

O .dat e .spr originais do client não são editaveis no Obejct Buildes. 
Eu tento abrir e fala que a versão não é suportada

Todos poketibias são compativeis com o object builder oficial, pq todos são 8.54.
O que deve estar acontecendo ai é que voce está editando o .spr e .dat com o otclient aberto ai não está salvando 
Otclient roda todas versões de tibia

O nome dos monstros voce configura é em data/monsters/monsters.xml e no arquivo .xml de cada monstro...
Execute o object builder como administrador e o editor de xmls (recomendo usar notepad ++)

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...