Jump to content
  • 0

Pokemon nao segue o player


raulcdj

Question

  1. Eu estou precisando de uma ajuda ate te pago se conseguir resolver
  2. o Pokémon sceptile e nem de mais da 3 geração não segue o personagem  estou adicionado ele agora e ele não me segue como o dragonite da 1 geração por exemplo alguém poderia me ajudar  vou deixa um vídeo para vocês ver como esta acontecendo.
Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Você precisará adicionar lógica para lidar com a distância entre o jogador e o Pokémon, como parar de seguir quando estiver muito longe ou ajustar a velocidade de movimento do Pokémon com base na distância.

 

 

E mais facil voce copia um mostro na pasta do seu servidor e colar 

dps muda o nome do pokemon copiado pra sceptile

e muda o id do pokemon pra evitar bug

 

Link to comment
Share on other sites

  • 0
Em 04/04/2023 em 18:48, red X disse:

Você precisará adicionar lógica para lidar com a distância entre o jogador e o Pokémon, como parar de seguir quando estiver muito longe ou ajustar a velocidade de movimento do Pokémon com base na distância.

 

 

E mais facil voce copia um mostro na pasta do seu servidor e colar 

dps muda o nome do pokemon copiado pra sceptile

e muda o id do pokemon pra evitar bug

 

vlw consegui resolver

 

Link to comment
Share on other sites

  • 0
Em 09/04/2023 em 15:41, raulcdj disse:

vlw consegui resolver

 

Como está o arquivo XML? 

 

Provavelmente você não colocou a propriedade summonable como '1':

 

<flag summonable="1"/>

 

Mas é bom fazer o que o red X falou, na dúvida, copia o arquivo de outro monster que já funciona e substitui pelo novo.

 

Mas seria bom informar qual era o problema e qual foi a solução, para que outras pessoas com os mesmos problemas no futuro consigam ver a solução.

Link to comment
Share on other sites

  • 0
16 horas atrás, Yan Oliveira disse:

Como está o arquivo XML? 

 

Provavelmente você não colocou a propriedade summonable como '1':

 

<flag summonable="1"/>

 

Mas é bom fazer o que o red X falou, na dúvida, copia o arquivo de outro monster que já funciona e substitui pelo novo.

 

Mas seria bom informar qual era o problema e qual foi a solução, para que outras pessoas com os mesmos problemas no futuro consigam ver a solução.

<?xml version="1.0" encoding="UTF-8"?>
<monster name="Walrein" nameDescription="a Walrein" race="water" experience="484" speed="117" manacost="0">
  <health now="160" max="160"/>
  <look type="2006" head="75" body="80" legs="95" feet="113" corpse="15819"/>
  <targetchange interval="10000" chance="0"/>
  <strategy attack="100" defense="0"/>
<flags>
 <flag summonable="1"/>
 <flag attackable="1"/>
 <flag hostile="1"/>
 <flag illusionable="1"/>
 <flag convinceable="1"/>
 <flag pushable="1"/>
 <flag canpushitems="0"/>
 <flag canpushcreatures="0"/>
 <flag targetdistance="1"/>
 <flag staticattack="97"/>
 <flag runonhealth="0"/>
 <flag hungerdelay="18"/>
</flags>

<attacks>
        <attack name="melee" interval="2000" chance="100" range="1" min="-50" max="-100">  </attack>
        <attack name="Lick" interval="2570" chance="31" range="1">
        </attack>
        <attack name="Water Pulse" interval="2852" chance="29" range="4">
        </attack>
        <attack name="Aurora Beam" interval="3040" chance="28" range="6">
        </attack>
        <attack name="Harden" interval="5625" chance="18" range="6">
        </attack>
        <attack name="Waterball" interval="2899" chance="29" range="4">
        </attack>
        <attack name="Ice Beam" interval="3416" chance="26" range="6">
        </attack>
        <attack name="Blizzard" interval="3933" chance="22" range="6">
        </attack>
</attacks>


<defenses armor="0" defense="0">
</defenses>

 <voices interval="5000" chance="10">
 <voice sentence="Walrein!"/>
 </voices>

  <loot>
          <item id="12779" chance="50" countmax="50"/>
        <item id="12778" chance="25" countmax="50"/>
        <item id="12785" chance="5" countmax="50"/>
  </loot>

<script>
<event name="Spawn"/>
</script>
</monster>

 

 

 

fiz isso copiei oque estava fucinado e voltou ao normal

 

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...