Jump to content
×
×
  • Create New...
  • 0

Converter sprites 8.54 para 10+


KyoGron
 Share

Question

Olá boa tarde,

Gostaria de saber se há um modo de exportar sprites em 8.54 e importar em uma versão 10+ do Tibia.. 

Estou parando de trabalhar com tfs 0.3.6 e começando em 1.3... mas está complicado importar magic effects/outfits etc.. sempre que importo eu preciso montar todas as movimentações.

Link to post
Share on other sites

Recommended Posts

  • 0
30 minutos atrás, KyoGron disse:

Olá boa tarde,

Gostaria de saber se há um modo de exportar sprites em 8.54 e importar em uma versão 10+ do Tibia.. 

Estou parando de trabalhar com tfs 0.3.6 e começando em 1.3... mas está complicado importar magic effects/outfits etc.. sempre que importo eu preciso montar todas as movimentações.

Quando estava em andamento o projeto ruby era só importando msm, da uma olhada la deve até ter o data e  spr  ja com os itens

Edited by mister17
Link to post
Share on other sites

  • 0
1 hora atrás, isabelle disse:

do 8.54 ele da de usar ate na versao 10.41, acima disso se nao me engano vc tem que recortar elas denovo kkk

 

Não precisa, pasta exportar e importar

Link to post
Share on other sites

  • 0
3 horas atrás, mister17 disse:

Quando estava em andamento o projeto ruby era só importando msm, da uma olhada la deve até ter o data e  spr  ja com os itens

Bom então, estou usando o mesmo.. o problema é que, estou realocando os efeitos, alterando alguns e removendo os padrões do tibia, já que estou usando os da pxg, o problema é que, ao exportar a spr em 8.54 não consigo importar no do Ruby.. porque preciso montar tudo de vagar, ai por exemplo o efeito da pokéball que usa 60 movimentações, eu preciso montar todas as 60.. isso ai quebra kkk 

 

Link to post
Share on other sites

  • 0
24 minutos atrás, KyoGron disse:

Bom então, estou usando o mesmo.. o problema é que, estou realocando os efeitos, alterando alguns e removendo os padrões do tibia, já que estou usando os da pxg, o problema é que, ao exportar a spr em 8.54 não consigo importar no do Ruby.. porque preciso montar tudo de vagar, ai por exemplo o efeito da pokéball que usa 60 movimentações, eu preciso montar todas as 60.. isso ai quebra kkk 

 

Você consegue escolher a versão do obd ao exportar no Object Builder, é só colocar 10.x e depois importar dnv

Link to post
Share on other sites

  • 0
1 minuto atrás, lSainty disse:

Você consegue escolher a versão do obd ao exportar no Object Builder, é só colocar 10.x e depois importar dnv

É ai que tá, quando eu faço isso, simplesmente não vai para o lado esquerdo, vai para o lado direito somente e eu preciso montar do mesmo jeito.

 

 

Estou postando um gif de demonstração abaixo para ficar mais claro.

 

Link to post
Share on other sites

  • 0
3 minutos atrás, KyoGron disse:

É ai que tá, quando eu faço isso, simplesmente não vai para o lado esquerdo, vai para o lado direito somente e eu preciso montar do mesmo jeito.

 

Te falar que nunca vi isso acontecer uhasuhsauhsa
Está usando a versão mais recente do OB? Também é possível alterar a versão do .obd ao exportar, tem v1 e v2 se não me engano, vê se alguma das duas funciona hahaha

Link to post
Share on other sites

  • 0
Agora, lSainty disse:

Te falar que nunca vi isso acontecer uhasuhsauhsa
Está usando a versão mais recente do OB? Também é possível alterar a versão do .obd ao exportar, tem v1 e v2 se não me engano, vê se alguma das duas funciona hahaha

Então, estou usando uma versão aqui do fórum, que eu encontrei modificada é 0.3.3 mas aceita as signatures acima de 10.98, usando a 0.4.8 (mais atual do github) não consigo abrir a spr do Ruby que é 10.98 e mesmo alterando a versão dele utilizando o object 0.3.3 para 8.54 ou 10.56 ou até mesmo 10.41 o mesmo não abre no object builder 0.4.8.

Link to post
Share on other sites

  • 0
3 minutos atrás, KyoGron disse:

Então, estou usando uma versão aqui do fórum, que eu encontrei modificada é 0.3.3 mas aceita as signatures acima de 10.98, usando a 0.4.8 (mais atual do github) não consigo abrir a spr do Ruby que é 10.98 e mesmo alterando a versão dele utilizando o object 0.3.3 para 8.54 ou 10.56 ou até mesmo 10.41 o mesmo não abre no object builder 0.4.8.

Creio que vale a pena você ver como alterar a versão 0.4.8 para aceitar as signatures do 10.98 pq esse 0.3.3 é bem antigo, tem vários bugs D;
No Discord do Ruby um cara tinha explicado uma vez mas nem me recordo exatamente como era, da uma olhada nesse arquivo: https://github.com/ottools/ObjectBuilder/blob/master/src/firstRun/versions.xml

Link to post
Share on other sites

  • 0
16 minutos atrás, lSainty disse:

Creio que vale a pena você ver como alterar a versão 0.4.8 para aceitar as signatures do 10.98 pq esse 0.3.3 é bem antigo, tem vários bugs D;
No Discord do Ruby um cara tinha explicado uma vez mas nem me recordo exatamente como era, da uma olhada nesse arquivo: https://github.com/ottools/ObjectBuilder/blob/master/src/firstRun/versions.xml

Eu estou atrás do Discord do Ruby, mas sem sucesso.. todos os links estão expirados.

 

Link to post
Share on other sites

  • 0
8 minutos atrás, KyoGron disse:

Eu estou atrás do Discord do Ruby, mas sem sucesso.. todos os links estão expirados.

 

Ele excluiu o Discord, tenta contato com o Majesty que talvez ele te ajude em algo

edit: é Majesty#8195 o Discord dele

Edited by lSainty
Link to post
Share on other sites

  • 0
2 minutos atrás, KyoGron disse:

Tentei.. mas pelo visto foi sem sucesso 

 

Acabei de alterar o comentário com o discord dele, no momento ele esta off, mas quando ele entrar com certeza ele te ajuda (embora provavelmente seja só alterar aquele arquivo que mandei hahaha)

Link to post
Share on other sites

  • 0
1 minuto atrás, lSainty disse:

Acabei de alterar o comentário com o discord dele, no momento ele esta off, mas quando ele entrar com certeza ele te ajuda (embora provavelmente seja só alterar aquele arquivo que mandei hahaha)

Estou baixando o Visual Studio 2019 pra compilar o object 

 

Link to post
Share on other sites

  • 0

Boa noite pessoal,

 

Só vindo aqui para avisar que consegui "Resolver" o meu problema, usei um programa do Mignari, tive que compilar o mesmo, foi coisa rápida.

Consegui converter e remover frame groups e uma outra parte na qual esqueci..

Mas com isto, consigo importar as sprites da versão 8.54 para a versão 10+ com facilidade.. assim como posso usar clientes do tibia 10+ em versões 8.54, 8.60 etc..

 

Segue link abaixo do programa:

https://github.com/ottools/ClientConverter/tree/master/ClientConverter

 

EDIT: Se algum moderador puder fechar o tópico e botar como solucionado, agradeço.

Edited by KyoGron
Comentário para modificar tópico para solucionado.
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.