Jump to content
×
×
  • Create New...
  • 0

[ERRO] Database SQLite Studio do meu server


Go to solution Solved by Polguilo,

Question

salvee galera do XTibia,feliz ano novo pra geral =DD
esses dias decidi rodar meu server dps de mt tempo sem nem sequer dar as caras nele,dai eu abro a Database do SQLite Studio meu server pra olhar algumas coisas e eu me deparo com um erro...

antes de mais nada queria avisar que manjo pouca coisa sobre scrip/programação/SQL e talz,dai eu n sei como isso aconteceu ou muito menos qual foi a causa dele
n sei se foi o Windows burro q deletou alguma DLL por causa do antivirus,se foi por causa de alguns desligamentos inesperados ja que meu PC ta com a bateria zuada ou sei la...
MAAAASSSSS de resto ta tudo funcionando normalmente no meu server,os comandos do God e tudo mais até onde eu sei apesar de não ter testado muito,porem só n consigo ter acesso a database por causa desse erro infeliz ¬¬'
isso n acontece só na table "players" mas sim em todas,então basicamente não consigo nem editar ou ver qualquer table =|
OBS: não sei se tem alguma relação,mas o meu antivirus ta deletando direto o a minha distro (.exe) do meu server e.e



agradeço quem puder me ajudar com qualquer informação relacionada,peço desculpa se postei o tópico no lugar errado kkkkkkkkkkk

enfim,o erro que aparece ao clicar em qualquer "Table" da database do meu server no SQLite Studio é esse:

 

Spoiler



can't read "hndClass(Enterprise)": no such element in array
    while executing
"$hndClass($defHnd) ::#auto"
    (procedure "::Formatter::format" body line 14)
    invoked from within
"Formatter::format [decode $row(sql)]"
    invoked from within
"::database0 eval {SELECT sql FROM sqlite_master WHERE name = 'players'} row {
		$_sqlEditor setContents [Formatter::format [decode $row(sql)]]
		set S..."
    ("uplevel" body line 1)
    invoked from within
"uplevel [list $_db eval {*}$args]"
    while executing
"error $::errorInfo"
    (object "::sqlite30" method "::DB::eval" body line 9)
    invoked from within
"$_db eval "SELECT sql FROM sqlite_master WHERE name = '[string map [list ' ''] $_table]'" row {
		$_sqlEditor setContents [Formatter::format [decode $..."
    (object "::tableWin0" method "::TableWin::refreshColumns" body line 4)
    invoked from within
"refreshColumns"
    while constructing object "::tableWin0" in ::TableWin::constructor (body line 160)
    invoked from within
"TableWin ::#auto $title $db $table"
    (object "::.mainWin.d.l.sb" method "::DBTree::openTableWindow" body line 9)
    invoked from within
"openTableWindow $db [lindex $data 2]"
    ("TABLE" arm line 2)
    invoked from within
"switch -- [lindex $data 0] {
		"DATABASE" {
			if {[$db isOpen]} {
				if {[$_tree item isopen $it]} {
					$_tree item collapse $it
				} else {
				..."
    (object "::.mainWin.d.l.sb" method "::DBTree::doubleClicked" body line 10)
    invoked from within
"::.mainWin.d.l.sb doubleClicked 79 446"
    (command bound to event)

 

Edited by Polguilo
Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0
  • Solution

enfim,eu mesmo RESOLVI galera! haha

como eu resolvi?
bom,eu simplesmente baixei a versão 3.2.1 do SQLite Studio,que é a mais recente sendo que eu usava uma bem mais antiga que era a 1.1.3 e abri a database ja existente do meu server,agora as tables e todo restante funcionam normalmente =))

então essa é a dica pra quem ta passando por isso quando sua database decide ir pro quiabo do nada kkkkkkkkkkkk
@dso15 manow,agradeço do memo jeito pela sua boa vontade em querer me ajudar - tenha uma boa semana e sucesso sempre o/

Link to post
Share on other sites
  • 0

@dso15
acho q vai ser o jeito mano,foda que ngm por enquanto brotou aqui pra dar um help :x
acho q nem deve ser algo sério,tbm n sei se corrompeu a database ou sei la e.e

ta td funcionando zero bala no server,só a database que ta dando esse erro ai que impede de eu abrir pra editar alguma coisa se eu precisar :x
vc sabe oq pode ter acontecido mano??? tem alguma desvantagem se eu mudar pro My SQL pow??

Link to post
Share on other sites
  • 0
9 horas atrás, Polguilo disse:

@dso15
acho q vai ser o jeito mano,foda que ngm por enquanto brotou aqui pra dar um help :x
acho q nem deve ser algo sério,tbm n sei se corrompeu a database ou sei la e.e

ta td funcionando zero bala no server,só a database que ta dando esse erro ai que impede de eu abrir pra editar alguma coisa se eu precisar :x
vc sabe oq pode ter acontecido mano??? tem alguma desvantagem se eu mudar pro My SQL pow??

como disse pode ter sido varias posibilidades uma dll excluida pelo anti virus, um exe corompido , porem vc pode extrair as dll os exe do server e a database dnv se isso nao funcionar vai pra mysql msm

 

Link to post
Share on other sites
  • 0

@dso15
mas ta td certo irmão,tipo eu consigo usar todos os comandos e fazer praticamente tudo - pelo menos até onde eu testei kkkk

o .exe do server roda de boas sem dar nenhuma treta,como tenho uma cópia do server "stock" sem nenhuma alteração minha eu até tentei abrir algumas tables porem msm assim da esse memo errado maldito kkkkkkkk

então eu n sei oq ta pegando =|

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now