Jump to content
  • 0

[URGENTE] Client OTC carrega sprites indefinidas.


Dann123

Question

Bom primeiramente quero lhes informar que estou usando a base dxp e decidi criar um cliente novo pra alterar o andar diagonal, pois o mesmo estava andando com delay..

"Ah, mas você podia alterar a sources do seu client e compilar de novo" Ja tentei fazer isso... E não consegui, caso alguém saiba como fazer, tô ai..

 

Então... pesquisei bastante e encontrei, ok.. baixei as sources, compilei e gerou um .exe OTC blz..

Ai eu peguei todo o data e modules do meu cliente dxp e coloquei nesse novo cautelosamente, para não gerar bugs e consegui!!

 

Criei um cliente igual ao antigo, porem com uma OTC mais atualizada e agora com meu andar diagonal melhorado também, mas... ficou apenas 1 bug que eu não to conseguindo resolver, isto é, carregar as sprites do meu servidor...

E este aqui é do meu cliente original do DXP

Eu não sei o que é, pois copiei e colei o dat e o spr do DXP no meu cliente novo...

Talvez seja pq o spr do DXP esteja criptografado ou até mesmo alguma cagada que fiz na compilação, porque eu tava lendo um post aqui no xTibia e vi que poderia ser algo do tipo na compilação na hora de selecionar transparência, não sei...

Mas por favor... se alguém souber da um help ai, vlw!!

 

Rep++ pra quem tiver qualquer ideia do que seja!!

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Estou exatamente com o mesmo problema. compilei meu cliente sem nem um erro.
mas quando fui entrar no jogo ficou assim.  se você conseguir resolver, poderia colocar a solução aqui ?

 

bug.png

Edited by adrianokk
Link to comment
Share on other sites

  • 0
Em 24/02/2020 em 21:16, Dann123 disse:

Bom primeiramente quero lhes informar que estou usando a base dxp e decidi criar um cliente novo pra alterar o andar diagonal, pois o mesmo estava andando com delay..

"Ah, mas você podia alterar a sources do seu client e compilar de novo" Ja tentei fazer isso... E não consegui, caso alguém saiba como fazer, tô ai..

 

Então... pesquisei bastante e encontrei, ok.. baixei as sources, compilei e gerou um .exe OTC blz..

Ai eu peguei todo o data e modules do meu cliente dxp e coloquei nesse novo cautelosamente, para não gerar bugs e consegui!!

 

Criei um cliente igual ao antigo, porem com uma OTC mais atualizada e agora com meu andar diagonal melhorado também, mas... ficou apenas 1 bug que eu não to conseguindo resolver, isto é, carregar as sprites do meu servidor...

  Ocultar conteúdo

E este aqui é do meu cliente original do DXP

  Ocultar conteúdo

Eu não sei o que é, pois copiei e colei o dat e o spr do DXP no meu cliente novo...

Talvez seja pq o spr do DXP esteja criptografado ou até mesmo alguma cagada que fiz na compilação, porque eu tava lendo um post aqui no xTibia e vi que poderia ser algo do tipo na compilação na hora de selecionar transparência, não sei...

Mas por favor... se alguém souber da um help ai, vlw!!

 

Rep++ pra quem tiver qualquer ideia do que seja!!

Resolveram? estou com mesmo problema...

Em 09/03/2020 em 12:13, adrianokk disse:

Estou exatamente com o mesmo problema. compilei meu cliente sem nem um erro.
mas quando fui entrar no jogo ficou assim.  se você conseguir resolver, poderia colocar a solução aqui ?

 

bug.png

se resolveu me avisa :)

 

Link to comment
Share on other sites

×
×
  • Create New...