KL

Gesior Shop Erro.

By Kloth, 07 de set. de 2010 in Archived

5
1.5k
KlothK
07 de setembro de 2010 às 18:43

Logo quando vo add algum item la no Shop, ou vo dar VIEW ou editar ele pra trocar alguma bobagem

da esse erro qdo vo dar ADD ITEM no shop

 

Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[42S22]: Column not found: 1054 Unknown column 'pid' in 'field list'' in C:\xampp\htdocs\shopadmin.php:61 Stack trace: #0 C:\xampp\htdocs\shopadmin.php(61): PDO->query('INSERT INTO `z_...') #1 C:\xampp\htdocs\index.php(225): include('C:\xampp\htdocs...') #2 {main} thrown in C:\xampp\htdocs\shopadmin.php on line 61

 

 

Quando vo dar VIWER/Editar algum item esse erro eh mostrado..

Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[42S22]: Column not found: 1054 Unknown column 'pid' in 'field list'' in C:\xampp\htdocs\shopadmin.php:102 Stack trace: #0 C:\xampp\htdocs\shopadmin.php(102): PDO->query('SELECT id, poin...') #1 C:\xampp\htdocs\index.php(225): include('C:\xampp\htdocs...') #2 {main} thrown in C:\xampp\htdocs\shopadmin.php on line 102

 

 

 

Se alguem souber como arruma por favor agradeço MUITO!

 

ps: esse erro aconteçeu logo dps que migrei o site para o dedicado, dentro das pastas do Site/Ot tao as configs do shop sistem pra poder enviar o item pro player.

 

Agradeço desde JA!.

07 de setembro de 2010 às 18:56

quando você add um novo item no shop, ele e gravado na database (dados,points,nome,observação e etc)

 

o que pode ter ocorrido, é que na migração você perde esses dados, ou crio uma nova database.

 

eu recomendo você apagar todos os itens, (no site e na database, na coluna shop)

 

e add tudo de volta, para que n haja esse conflito.

 

abraços

KlothK
07 de setembro de 2010 às 22:46

Okay irei tentar qual quer coisa posto aqui obrigado.!

1 month later...
KanniggiaK
14 de outubro de 2010 às 11:20

@felipedorgas

 

Estou exatamente com esse mesmo problema fiz oq vc falou não adiantou nd =/

 

Por favor alguem ajuda.

 

Obrigado. :smile_positivo:

Natanael BeckmanN
14 de outubro de 2010 às 16:29

Vai na pasta do seu ot em htdocs add uma pasta com o nome data e dentro dela bota a pasta items do seu ot.

Pronto resolvido.